Telephony Problems
Incident Report for Spintr
Resolved
This incident has been resolved.
Posted May 06, 2024 - 12:59 CEST
Investigating
We are currently experiencing issues with our telephony solutions, as a result, incoming calls to our customer service line may not connect. If you need to get in touch with our customer service, please email us at support@spintr.me
Posted May 03, 2024 - 15:26 CEST