Image rendering issues
Incident Report for Spintr
Resolved
The issue was resolved on December 7th.
Posted Dec 22, 2023 - 10:55 CET
Identified
We've identified an issue with image rendering in the latest version of Google Chrome. Images are rendered as blurry and cannot be expanded. We're working fixing the issue and will be deploying an update tomorrow (December 7th).
Posted Dec 06, 2023 - 16:15 CET
This incident affected: Spintr.